# Table of Contents

Foreword .......................................................................................................................... 11
Acknowledgements .......................................................................................................... 12
Chapter 1. Introduction .................................................................................................... 13
1.1. Purpose and structure of this book ........................................................................... 13
1.2. KNIME community .................................................................................................. 14
   Useful Web Pages .......................................................................................................... 14
   Courses, Events, and Videos ......................................................................................... 15
   Books ............................................................................................................................. 16
   KNIME Community Hub ............................................................................................... 16
1.3. Download and install KNIME Analytics Platform ..................................................... 20
1.4. Workspace ................................................................................................................. 21
   The “Workspace Launcher” .......................................................................................... 21
1.5. KNIME workflow ...................................................................................................... 22
   What is a workflow ....................................................................................................... 22
   What is a node .............................................................................................................. 23
1.6. *knwf* and *knor* file extensions ............................................................................ 23
1.7. KNIME workbench .................................................................................................... 24
   The KNIME Workbench ............................................................................................... 25
   Top menu ...................................................................................................................... 26
   Tool Bar ....................................................................................................................... 30
   Hotkeys ....................................................................................................................... 31
   Node Repository ......................................................................................................... 32
   Search box ................................................................................................................... 32
   KNIME Explorer ......................................................................................................... 32
   My-KNIME-Hub .......................................................................................................... 33
# Chapter 2. My first workflow

- **Node operations**
  - Create a new node
  - Configure a node
  - Execute a node
  - Node Text
  - View the processed data

## 2.1. Workflow operations

- Create a new Workflow Group
- Create a new workflow
- Save a workflow
- Delete a workflow

## 2.2. Node operations

- Create a new node
- Configure a node
- Execute a node

## 1.9. Data and workflows for this book

- Exercise 1
- Exercise 2
- Exercise 3

## 1.10. Exercises

1. **Download the KNIME Extensions**
2. **Installing KNIME Extensions**
3. **Mounting KNIME Business Hub in KNIME Explorer**
4. **Customizing the Workflow Editor**
5. **Workflow Annotations**
6. **Other Workbench Customizations**
7. **Node Monitor View**

- **View the processed data**
2.3. Read data from a file.................................................................54
   Create a “CSV Reader” node ....................................................54
   Configure the “CSV Reader node ............................................55
   Customizing Column Properties ..............................................56
   The knime:// protocol ...........................................................58
2.4. KNIME data structure and data types .....................................59
   KNIME data structure ...........................................................61
2.5. Filter Data Columns ...............................................................61
   Create a “Column Filter” node ................................................62
   Configure the “Column Filter” node ........................................64
2.6. Filter Data Rows .....................................................................65
   Create a “Row Filter” node ......................................................66
   Configure the “Row Filter” node .............................................66
   Row filter criteria .....................................................................68
2.7. Write Data to a File .................................................................70
   Create a “CSV Writer” node .....................................................70
   Configure the “CSV Writer” node ............................................71
2.8. Exercises ................................................................................72
   Exercise 1 .................................................................................72
   Exercise 2 .................................................................................75
Chapter 3. My first data exploration ..............................................79
3.1. Introduction ............................................................................79
3.2. Replace Values in Columns ....................................................80
   Column Rename ........................................................................81
   Rule Engine ..............................................................................83
3.3. String Splitting .......................................................................85
3.4.  String Manipulation ................................................................. 89

String Manipulation ................................................................. 89
Case Converter ......................................................................... 91
String Replacer ......................................................................... 92
Column Combiner ...................................................................... 93
Column Resor ter ....................................................................... 94

3.5.  Type Conversions ................................................................. 95

Number To String ........................................................................ 96
String To Number ........................................................................ 97
Double To Int ............................................................................. 98

3.6.  Database Operations .......................................................... 98

SQLite Connector ......................................................................... 100
MySQL Connector ........................................................................ 101
Workflow Credentials ................................................................... 102
DB Writer .................................................................................. 104
Import a JDBC Database Driver ................................................... 104
DB Table Selector ......................................................................... 107
DB Reader .................................................................................. 108

3.7.  Aggregations and Binning .................................................... 108

Numeric Binner .......................................................................... 110
GroupBy: “Groups” tab ............................................................... 111
GroupBy: Aggregation tabs .......................................................... 112
Pivoting ...................................................................................... 113
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normalization Methods</td>
<td>146</td>
</tr>
<tr>
<td>Normalizer (Apply)</td>
<td>146</td>
</tr>
<tr>
<td>4.4. Machine Learning Models</td>
<td>147</td>
</tr>
<tr>
<td>Naïve Bayes Model</td>
<td>148</td>
</tr>
<tr>
<td>Naïve Bayes Learner</td>
<td>149</td>
</tr>
<tr>
<td>Naïve Bayes Predictor</td>
<td>149</td>
</tr>
<tr>
<td>Scorer (Javascript)</td>
<td>151</td>
</tr>
<tr>
<td>Decision Tree</td>
<td>155</td>
</tr>
<tr>
<td>Decision Tree Learner: Options Tab</td>
<td>156</td>
</tr>
<tr>
<td>Decision Tree Learner: PMML Settings Tab</td>
<td>157</td>
</tr>
<tr>
<td>Decision Tree Predictor</td>
<td>158</td>
</tr>
<tr>
<td>Decision Tree View</td>
<td>163</td>
</tr>
<tr>
<td>ROC Curve</td>
<td>164</td>
</tr>
<tr>
<td>Artificial Neural Network</td>
<td>166</td>
</tr>
<tr>
<td>RProp MLP Learner</td>
<td>166</td>
</tr>
<tr>
<td>Multilayer Perceptron Predictor</td>
<td>168</td>
</tr>
<tr>
<td>Write/Read Models to/from file</td>
<td>169</td>
</tr>
<tr>
<td>Model Writer</td>
<td>169</td>
</tr>
<tr>
<td>Model Reader</td>
<td>171</td>
</tr>
<tr>
<td>Statistics</td>
<td>172</td>
</tr>
<tr>
<td>Regression</td>
<td>174</td>
</tr>
<tr>
<td>Linear Regression Learner</td>
<td>175</td>
</tr>
<tr>
<td>Regression Predictor</td>
<td>176</td>
</tr>
<tr>
<td>Clustering</td>
<td>176</td>
</tr>
<tr>
<td>k-Means</td>
<td>177</td>
</tr>
<tr>
<td>Cluster Assigner</td>
<td>178</td>
</tr>
<tr>
<td>Section</td>
<td>Title</td>
</tr>
<tr>
<td>---------</td>
<td>-------</td>
</tr>
<tr>
<td>Select Data</td>
<td>..........................................................</td>
</tr>
<tr>
<td>Format Chart</td>
<td>..........................................................</td>
</tr>
<tr>
<td>7.10.</td>
<td>Style Sheets</td>
</tr>
<tr>
<td>Create a new Style Sheet</td>
<td>..........................................................</td>
</tr>
<tr>
<td>Apply a Style Sheet</td>
<td>..........................................................</td>
</tr>
<tr>
<td>7.11.</td>
<td>Generate the final document</td>
</tr>
<tr>
<td>7.12.</td>
<td>Dynamic Text</td>
</tr>
<tr>
<td>7.13.</td>
<td>Reporting with other Tools</td>
</tr>
<tr>
<td>7.14.</td>
<td>Exercises</td>
</tr>
<tr>
<td>Exercise 1</td>
<td>..........................................................</td>
</tr>
<tr>
<td>References</td>
<td>..........................................................</td>
</tr>
<tr>
<td>Node and Topic Index</td>
<td>..........................................................</td>
</tr>
</tbody>
</table>
Foreword

This is the first book I wrote in 2010 for the KNIME Press on how to use KNIME Analytics Platform. Since we are getting close to the 10-year anniversary of this book, we (the KNIME Press Team and I) thought that it might be in need of a new Foreword text. It does not actually need an overall update, as ever since its birth it has been updated twice a year every year, following each new release of KNIME Analytics Platform; not immediately after - but close enough.

That is right! KNIME Beginner’s Luck, like all other e-books from KNIME Press, is a live e-book, constantly changing to fit the newest version of the software. This liveness of the e-book is also the reason why it has only rarely been printed. Updating printed pages is undoubtedly harder than updating a pdf file!

As this is the first book, it is inevitably about the basics: the basics of KNIME Analytics Platform of course and also the basics of a data science project. This book guides you through the most important access functions, data transformation operations, and of course machine learning nodes available in KNIME Analytics Platform. Supplemented with many example workflows, exercises, and screenshots, it will quickly familiarize you with the basic functions of the software. If you are looking for more advanced topics, you won’t find them here, instead....

If you want to learn more about advanced machine learning algorithms, flow variables, or loops, check the sequel to this book: “KNIME Advanced Luck”. If you want to learn more about text processing, have a look at the book, “From Words To Wisdom”. If you come from that school of thoughts where reading manuals or instructions is overrated, you can start directly with reading about solutions to case studies in various application fields in our collection “Practicing Data Science”. If your job is more about integrating and blending different data sources and data types, then the book for you is the “Will they blend?” collection. More useful booklets are available on the KNIME Press page, if you are transitioning from SAS, Excel, or Alteryx.

All this is to say that the KNIME Press team and I have been working hard to provide you with the learning material, books, and tutorials, to become progressively more and more productive with KNIME Software and data science concepts.

Rosaria Silipo (Author of a number of KNIME Press Books, PhD)
Acknowledgements

First of all, I would like to thank the whole KNIME Team for their patience in dealing with me and my infinite questions.

Among all others in the KNIME Team I would like to specifically thank Peter Ohl for having reviewed this book in order to find any possible aspects that were not compatible with KNIME best practice.

I would also like to thank Casiana Rimbu for the help in providing the most beautiful, clear, and artistic screenshots I could ever imagine and Meta Brown for encouraging me in the first steps of developing the embryonic idea of writing this book.

Many thanks finally go to Heather Fyson for reviewing the book’s English.
Chapter 1. Introduction

1.1. Purpose and structure of this book

We live in the age of data! Every purchase we make is dutifully recorded; every money transaction is carefully registered; every web click ends up in a web click archive. Nowadays everything carries an RFID chip and can record data. We have data available like never before. What can we do with all these data? Can we make some sense out of it? Can we use it to learn something useful and profitable? We need a tool, a surgical knife that can empower us to cut deeper and deeper into our data, to look at it from many different perspectives, to represent its underlying structure.

Let’s suppose then that we have this huge amount of data already available, waiting to be dissected. What are the options for a professional to enter the world of Business Intelligence (BI) and Data Science (DS)? The options available are of course multiple and growing rapidly. If our professional does not control an excessive budget, he or she could turn to the world of open-source software. Open-source software, however, is more than a money driven choice. In many cases it represents a software philosophy for resource sharing and control that many professionals support.

Inside the open-source software world, we can find a few Data Science and BI tools. KNIME Analytics Platform represents an easy choice for the non-initiated professional. It does not require learning a specific script and it offers a Graphical User Interface (GUI) to implement and document analysis procedures. In addition - and this is not a secondary advantage - KNIME Analytics Platform can work as an integration platform into which many other BI and Data Science tools can be plugged. It is then not only possible but even easy to analyze data with KNIME Analytics Platform and then to build dashboards on the same processed data with a different BI tool.

Even though KNIME Analytics Platform is very simple and intuitive to use, any beginner would profit from an accelerated orientation through all of the nodes, categories, and settings. This book represents the beginner’s luck, because it is aimed to help any beginner to gear up his/her learning process. This book is not meant to be an exhaustive guide to the whole KNIME software. It does not cover implementations under the KNIME Business Hub, which is not open-source, or topics which are considered advanced. Flow Variables, for example, and implementations of database SQL queries are discussed in the sequel book “KNIME Advanced Luck”.

This book is divided into six chapters. The first chapter covers the basic concepts of KNIME Analytics Platform, while chapter two takes the reader by the hand into the implementation of the very first KNIME application. From the third chapter, we start the exploration of data science concepts in a more in-depth manner. The third chapter indeed explains how to perform some basic data exploration and visualization, in terms of nodes and processing flow. Chapter four is dedicated to data modeling. It covers a few demonstrative approaches to machine learning, Naïve Bayes, decision trees, and artificial neural networks. Finally, chapters five and six are dedicated to reporting. Usually, the results of an investigation based on data visualization or, in a later phase, on data modeling must be shown at some point to colleagues, management, directors, customers, or external workers. Thus,
reporting is a very important phase at the end of the data analysis process. Chapter five shows how to prepare the data to export into a report, while chapter six shows how to build the report itself.

Each chapter guides the reader through an ETL or a machine learning (ML) process step by step. Each step is explained in detail and offers some explanations about alternative employments of the current nodes. At the end of each chapter several exercises are proposed to the reader to test and perfect what he/she has learned so far.

Examples and exercises in this book have been implemented using KNIME 4.5. They should also work under subsequent KNIME versions, although there might be slight differences in their appearance.

1.2. KNIME community

Being an open-source software, KNIME Analytics Platform benefits of a number of forums and groups of KNIME users all around the world. This is a good safety net for advises, hints, and learning material. We report below the most popular sites and groups.

<table>
<thead>
<tr>
<th>Useful Web Pages</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.knime.com">http://www.knime.com</a></td>
<td>The root page in the KNIME web site.</td>
</tr>
<tr>
<td><a href="https://www.knime.com/software-overview">https://www.knime.com/software-overview</a></td>
<td>The first place to look for an overview of all KNIME products. The open source KNIME Analytics Platform can be downloaded here.</td>
</tr>
<tr>
<td><a href="https://www.knime.com/knime-self-paced-courses">https://www.knime.com/knime-self-paced-courses</a></td>
<td>This is the root page of the KNIME self-paced courses (e-learning) where you can learn more about the specific KNIME functionalities. It covers the whole data science creation cycle from data access and data exploration to machine learning and control structures.</td>
</tr>
<tr>
<td><a href="https://hub.knime.com/">https://hub.knime.com/</a></td>
<td>The KNIME Community Hub is a public repository for KNIME material: workflows, examples, extensions, component templates, and nodes. If you want to start with practical examples, here you can find many according to the search term you type in.</td>
</tr>
<tr>
<td><a href="https://forum.knime.com/">https://forum.knime.com/</a></td>
<td>What I find particularly useful is the KNIME Forum. Here you can ask questions about how to use KNIME Analytics Platform or about how to extend it with new nodes. Someone from the KNIME community answers always and quickly.</td>
</tr>
</tbody>
</table>
## Courses, Events, and Videos

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Courses for KNIME Analytics Platform</strong></td>
<td>KNIME periodically offers onsite and online courses for KNIME software. This includes basic and advanced elements. To check for the next available date and to register, just go to the KNIME Events web page <a href="https://www.knime.com/learning/events">https://www.knime.com/learning/events</a> and select the tab Online Courses.</td>
</tr>
<tr>
<td><strong>KNIME Webinars</strong></td>
<td>A number of webinars are also frequently available on specific topics, like chemistry nodes, text mining, integration with other analytics tools, automated machine learning, deep learning, time series analysis, best practices, and so on. To know about the next scheduled webinars, check the KNIME Events web page at <a href="https://www.knime.com/learning/events">https://www.knime.com/learning/events</a> and select the tab Webinars.</td>
</tr>
<tr>
<td><strong>KNIME Meetups and KNIME Summits</strong></td>
<td>KNIME Meetups and KNIME Data Talks are held periodically all over the world. These are always good chances to learn more about KNIME software, to get inspired about new data science projects, and to get to know other people from the KNIME Community (<a href="https://www.knime.com/learning/events">https://www.knime.com/learning/events</a>)</td>
</tr>
<tr>
<td><strong>KNIME TV Channel on YouTube</strong></td>
<td>KNIME has its own video channel on YouTube, named KNIMETV. There, a number of videos are available to learn more about many different topics and specially to get updated about the new features in the new KNIME releases (<a href="http://www.youtube.com/user/KNIMETV">http://www.youtube.com/user/KNIMETV</a>)</td>
</tr>
</tbody>
</table>
Books

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Codeless Deep Learning with KNIME</td>
<td>It is possible to implement deep learning solutions also within KNIME Analytics Platform. This book K. Melcher, R. Silipo, “Codeless Deep Learning with KNIME”, Packt, 2020</td>
</tr>
</tbody>
</table>

KNIME Community Hub

However, there is a privileged place where to find information about KNIME nodes and example workflows for your next projects: the KNIME Community Hub ([https://hub.knime.com/](https://hub.knime.com/)).

The KNIME Community Hub is a repository of applications, components, and nodes to recycle, reuse, and assemble on KNIME Analytics Platform. Or as it says on the home page: The KNIME Community Hub is “the place to find and collaborate on KNIME workflows and nodes. Here you can find solutions for your data science questions.”

When you access the KNIME Community Hub the first time, you end up with the page in figure 1.1. This page offers a few links to the starting guide documentation, the KNIME Forum, and the KNIME blog. Most importantly at the top it offers a search box to find applications, nodes, and components uploaded by KNIME users in this shared place of the KNIME community.

1.1. The KNIME Community Hub home page at [https://hub.knime.com/](https://hub.knime.com/)
If we type “Customer Intelligence” in the search box, we end up with a list of nodes and workflows related with Customer Intelligence. Let’s select just “Workflows” in the top menu. Then below in figure 1.2 you can see the list of applications (workflows) implementing some aspects of Customer Intelligence - and appropriately tagged - as uploaded by users of the KNIME community. Indeed, you can upload your own developed applications on the KNIME Community Hub. All you need is an account with the KNIME Forum.

On the KNIME Community Hub you can also find official dedicated spaces with their own description and landing page. Try for example to type “Marketing” and select the tag “Marketing Analytics”. You will get 14 marketing analytics related solutions hosted in the marketing analytics space and described in the landing page on the right, including relevant links.
1.2. The list of applications (workflows) related (and tagged) with Marketing Analytics on the KNIME Community Hub

Clicking one of the applications in the list opens the corresponding page (Fig. 1.3), with a nice explanatory picture of the implemented workflow.

On the top right corner, you can see the button to log in with your KNIME account. Being logged in allows you to upload, download, comment, like, and update the spaces and workflows for which you have permissions. Below that, you can find the author picture and below that a number of utility buttons: to download the workflow, to like it, to drag & drop it into KNIME Analytics Platform, and to copy the short permanent link for this workflow to share.
If you hover over the author image, and if you have editing permissions for this Hub space, a pen will appear. Clicking on it will allow you to give other KNIME users the permission to upload and change this space.

Notice that the KNIME Community Hub is a repository for workflows, but also for nodes, components, and extensions.

1.3. The page dedicated to the application named "Customer Segmentation" on the KNIME Community Hub, with short link https://kni.me/w/37cHxqr6dbI1UeP

This workflow performs customer segmentation by means of clustering k-Means node. The second part of the workflow implements an interactive wizard on the WebPortal to visualize and label (or write notes) about the single clusters.
1.3. Download and install KNIME Analytics Platform

There are two available KNIME products:

- the open source KNIME Analytics Platform, which can be downloaded free of charge at https://www.knime.com/software under the GPL version 3 license
- the KNIME Business Hub, which is described at https://www.knime.com/knime-business-hub

Analytically speaking, the functionalities of the two products are the same. The KNIME Business Hub in addition includes a number of useful IT features for team collaboration, enterprise workflow deployment and management, data warehousing, integration, and scalability for the data science lab. In this book, however, we will work with KNIME Analytics Platform (open-source). To start playing with KNIME Analytics Platform, first, you need to download it to your machine.

**Download KNIME Analytics Platform**

- Go to www.knime.com
- In the upper right corner of the main page, click “Download”
- Provide a little information about yourself (that is appreciated), then proceed to step 2 “Download KNIME”
- Choose the version that suits your environment (Windows/Mac/Linux, 32 bit/64 bit, with or without Installer for Windows) optionally including all free extensions
- Accept the terms and conditions
- Start downloading. You will end up with a zipped (*.zip), a self-extracting archive file (*.exe), or an Installer application
- For .zip and .exe files, just unpack it in the destination folder. If you selected the installer version, just run it and follow the installer instructions.
1.4. Workspace

To start KNIME Analytics Platform, open the folder where KNIME has been installed and run knime.exe (or knime on a Linux/Mac machine). If you have installed KNIME using the Installer, then you can just click the icon on your desktop or on your Windows main menu.

If you are starting KNIME Analytics Platform for the first time, you will be asked if you want to share your usage statistics with KNIME. These numbers will be used to fuel the best practice recommendation engine provided within KNIME Analytics Platform workbench: the Workflow Coach. No personal information will ever reach KNIME and your anonymous statistics will never be shared with anybody.

After the splash screen, the “Workspace Launcher” window requires you to enter the path of the workspace.

The “Workspace Launcher”

The workspace is a folder where all preferences and applications (workflows), both developed and currently under development, are saved for the next KNIME session.

The workspace folder can be located anywhere on the hard-disk.

By default, the workspace folder is “..\knime-workspace”. However, you can easily change that, by changing the path proposed in the “Workspace Launcher” window, before starting the KNIME working session.

Once KNIME Analytics Platform has been opened, from within the KNIME workbench you can switch to another workspace folder, by selecting “File” in the top menu and then “Switch Workspace”. After selecting the new workspace, KNIME Analytics Platform restarts, showing the workflow list from the newly selected workspace. Notice that if the workspace folder does not exist, it will be automatically created.

If I have a large number of customers for example, I can use a different workspace for each one of them. This keeps my workspace clean and tidy and protects me from mixing up information by mistake. For this project I used the workspace “KNIME_4.3.1\book_workspace”.

1.5. The “Workspace Launcher” window
1.5. KNIME workflow

KNIME Analytics Platform does not work with scripts, it works with graphical workflows.

Small little icons, called nodes, are dedicated each to implement and execute a given task. A sequence of nodes makes a workflow to process the data to reach the desired result.

What is a workflow

A workflow is an analysis flow, i.e. the sequence of analysis steps necessary to reach a given result. It is the pipeline of the analysis process, something like:

Step 1. Read data
Step 2. Clean data
Step 3. Filter data
Step 4. Train a model

KNIME Analytics Platform implements its workflows graphically. Each step of the data analysis is implemented and executed through a little box, called node. A sequence of nodes makes a workflow.

In the KNIME whitepaper [1] a workflow is defined as follows: "Workflows in KNIME are graphs connecting nodes, or more formally, direct acyclic graphs (DAG)." [http://www.kdd2006.com/docs/KDD06_Demo_13_Knime.pdf]

Note. A workflow is a data analysis sequence, which in a traditional programming language would be implemented by a series of instructions and calls to functions. KNIME Analytics Platform implements it graphically. This graphical representation is more intuitive to use, lets you keep an overview of the analysis process, and makes for the documentation as well.
What is a node

A node is the single processing unit of a workflow.

A node takes a data set as input, processes it, and makes it available at its output port. The “processing” action of a node ranges from modeling - like an Artificial Neural Network Learner node - to data manipulation - like transposing the input data matrix - from graphical tools - like a scatter plot, to reading/writing operations.

Every node in KNIME has 4 states:

- Inactive and not yet configured → red light
- Configured but not yet executed → yellow light
- Executed successfully → green light
- Executed with errors → red with cross light

Nodes containing other nodes are called metanodes or components.

1.6. .knwf and .knar file extensions

KNIME workflows can be packaged and exported in .knwf or .knar files. A .knwf file contains only one workflow, while a .knar file contains a group of workflows. Such extensions are associated with KNIME Analytics Platform. A double-click opens the workflow(s) directly inside the platform.
1.7. KNIME workbench

After accepting the workspace path, the KNIME workbench opens on a “Welcome to KNIME” page. This page provides a few links to get started, such as for example to the KNIME Community Hub, to some basic documentation, to the current courses and events, to available updates, and so on. The “KNIME Workbench” consists of a top menu, a tool bar, and a few panels. Panels can be closed, re-opened, and moved around.

1.9. The KNIME workbench
The KNIME Workbench

**Top Menu:** File, Edit, View, Node, Help

**Tool Bar:** New, Save (Save As, Save All), Undo/Redo, Open Report (if reporting was installed), zoom (in %), Align selected nodes vertically/horizontally, Auto layout, Configure, Execute options, Cancel execution options, Reset, Edit node name and description, Open node’s first out port table, Open node’s table, Search on KNIME Hub, Workflow & Node Description, Workflow Coach, Server & Workflows, Node Repository, Overview, Console
first view, Open the “Add Meta node” Wizard, Append IDs to node names, Hide all node names, Loop execution options, Change Workflow Editor Settings, Edit Layout in Components, configure job manager.

**KNIME Explorer**
This panel shows the list of workflow projects available in the selected workspace (LOCAL), on the EXAMPLES, on the My-KNIME-Hub (your own space on the KNIME Community Hub), or on other connected KNIME Hub spaces.

**Workflow Editor**
The central area consists of the “Workflow Editor” itself.
A node can be selected from the “Node Repository” panel and dragged and dropped here, in the “Workflow Editor” panel.
Nodes can be connected by clicking the output port of one node and releasing the mouse either at the input port of the next node or at the next node itself.

**Node Description**
If a node or a workflow is selected, this panel displays a summary description of the node’s functionalities or the workflow’s meta information.

**Workflow Coach**
This is a node recommendation engine. It will provide the list of the top most likely nodes to follow the currently selected node.

**Node Repository**
This panel contains all the nodes that are available in your KNIME installation. It is something similar to a palette of tools when working in a report or with a web designer software. There we use graphical tools, while in KNIME we use data analytics tools.

**Outline**
The “Outline” panel contains a small overview of the contents of the “Workflow Editor”. The “Outline” panel might not be of so much interest for small workflows. However, as soon as the workflows reach a considerable size, all the workflow’s nodes may no longer be visible in the “Workflow Editor” without scrolling. The “Outline” panel, for example, can help you locate newly created nodes.

**Console**
The “Console” panel displays error and warning messages to the user.
This panel also shows the location of the log file, which might be of interest when the console does not show all messages.
There is a button in the tool bar as well to show the log file associated with this KNIME instance.

**Search box for KNIME Community Hub**
To search for material on the KNIME Community Hub

---

**Top menu**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td><strong>Edit</strong></td>
<td><strong>View</strong></td>
</tr>
</tbody>
</table>

---

26
**File** includes the traditional File commands, like “New” and “Save”, in addition to some KNIME specific commands, like:

- Import/Export KNIME workflow...
- Export to SVG
- Switch Workspace
- Preferences with Export/Import Preferences
- Install KNIME Extensions
- Update KNIME...
- Restart
- Exit

**Edit** contains edit commands.

- **Undo** and **Redo** refer to the last performed actions.
- **Cut**, **Copy**, **Paste**, and **Delete** refer to selected nodes in the workflow.
- **Select All** selects all the nodes of the workflow in the workflow editor.

**View** contains the list of all panels that can be opened in the KNIME workbench.

- A closed panel can be re-opened here.
- Also, when the panel disposition is messed up, the option “Reset Perspective” re-creates the original panel layout when the workbench was started for the first time.
- Option “Other” opens additional views useful to customize the workbench.
**Node** refers to all possible operations that can be performed on a node. A node can be:

- Configured
- Executed
- Cancelled (stopped during execution)
- Reset (resets the results of the last “Execute” operation)
- Given a name and description
- Set to show its View (if any)

Options are only active if they are possible. For example, an already successfully executed node cannot be re-executed unless it is first reset or its configuration has been changed. The “Cancel” and “Execute” options are then inactive.

Option “Open Meta Node Wizard” starts the wizard to create a new meta node in the workflow editor.

**Help Contents** provides general Help about the Workbench, BIRT, and KNIME.

**Search** opens a panel on the right of the “Node Description” panel to search for specific Help topics or nodes.

**Welcome Page** (re-)opens the Welcome Page

**Install New Software** is the door to install KNIME Extensions from the KNIME Update sites.

**Show Active Keybindings** summarizes all keyboard commands for the workflow editor.

**Cheat Sheets** offer tutorials on specific topics: the reporting tool, csv, Plug-ins.
Let’s now go through the most frequently used items in the Top Menu.

“File” → “Import KNIME workflow” reads and copies workflows into the current workspace.

Option “Select root directory” copies the workflow directly from a folder into the current workspace (LOCAL).
Option “Select archive file” reads a workflow from a .knwf or .knar file into the current workspace (LOCAL). .knwf/.knar files can be created through the option “File” → “Export KNIME workflow”.

“File” → “Export KNIME workflow” exports the one selected workflow to a .knwf or the many selected workflows to a .knar file.

Option “Reset Workflow(s) before export” exports fully reset workflows without the data produced by each node. This generates considerably smaller export files.

Simply copying a workflow from one folder to another can create a number of problems related to internal KNIME updates. Copying workflows by using the option “Import KNIME workflow” or by double-click is definitely safer.

“File” → “Install KNIME Extensions” and “Help” → “Install New Software” both link to the dialog window for the installation of KNIME Extensions from the KNIME Update sites (see next sections).

“File” → “Switch Workspace” changes the current workspace with a new one.

“File” → “Preferences” brings you to the window where all KNIME settings can be customized. They can be found under item “KNIME”. Let’s check them.

- **Chemistry** has settings related to the KNIME Renderers in the chemistry packages.
- **Databases** specifies the location of specific database drivers, not already available within KNIME. Indeed, the most common and most recent database drivers are already available in the driver menu of Database nodes. However, if you need some specific driver file, you can set its path here.
Export Preferences and Import Preferences in the “File” menu respectively exports and imports the “Preferences” settings into and from a *.epf file. These two commands come in handy when, for example, a new version of KNIME is installed and we want to import the old preferences settings.

**Tool Bar**

The tool bar is another important piece of the KNIME workbench.

From the left, we find the icon to create a new workflow, save the selected workflow, save as the selected workflow in another location, save all open workflows, undo and redo, switch to the reporting environment, zoom (in %), align selected nodes vertically, align selected nodes horizontally, auto-layout, configure the selected node, execute the selected node, execute all executable nodes, execute selected nodes and open the first data view, cancel selected running nodes, cancel all running nodes, reset selected nodes, edit description of selected node, open first data view of selected nodes, open views of selected nodes, open the Add Metanode Wizard, append IDs to node names, hide node names,

- **KNIME Explorer** contains the list of the shared repositories via KNIME Hub spaces.
- **KNIME GUI** allows the customization of the KNIME workbench options and layout via a number of settings.
- **Master Key** contains the master key to be used in nodes with an encryption option, like database connection nodes. Since KNIME 2.3 database passwords are passed via the “Credentials” workflow variables and the Master Key preference has been deprecated. You can still find it in the Preferences menu for backward compatibility.
- In **Meta Info Preferences** you can upload meta-info template for nodes and workflows.
- Here you can also find the preference settings for the **external packages**, like: H2O, R, Report Designer, Perl, Open Street Map, and others if you have them installed. In particular, for the external scripts, this page offers the option to set the path to the reference script installation.
- Finally, **Workflow Coach** contains the dataset to be used for the node recommendation engine: the community, a Hub workspace, or your own local workspace.
do one loop step, pause loop execution, resume loop execution, change workflow editor settings, open layout editor for components, configure job manager for all selected nodes. We will see all these options along the course of this book.

For now, I just want to describe the “Auto Layout” button. The auto-layout button automatically adjusts the position of the nodes in the workflow to produce a clean, ordered, and easy to explore workflow. This auto-layout operation becomes particularly useful when, for example after a long development session, the workflow overview has become difficult.

1.12. The "Auto Layout" button in the tool bar

For all keyboard lovers, most KNIME commands can also run via hotkeys. All hotkeys are listed in the KNIME menus on the side of the corresponding commands or in the tooltip messages of the icons in the Tool Bar under the Top Menu. Here are the most frequently used hotkeys.

**Hotkeys**

**Node Configuration**
- F6 opens the configuration window of the selected node

**Node Execution**
- F7 executes selected configured nodes
- Shift + F7 executes all configured nodes
- Shift + F10 executes all configured nodes and opens all views

**Stop Node Execution**
- F9 cancels selected running nodes
- Shift + F9 cancels all running nodes

**To move nodes**
- Ctrl + Shift + Arrow moves the selected node in the arrow direction

**Node Resetting**
- F8 resets selected nodes

**Save Workflows**
- Ctrl + S saves the workflow
- Ctrl + Shift + S saves all open workflows
- Ctrl + Shift + W closes all open workflows

**Meta-Node**
- Shift + F12 opens Meta Node Wizard

**To move Annotations**
- Ctrl + Shift + PgUp/PgDown moves the selected annotation in the front or in the back of all the overlapping annotations
Node Repository

In the lower left corner we find the Node Repository, containing all installed nodes organized in categories and subcategories. KNIME Analytics Platform has accumulated by now more than 1500 nodes. It has become hard to remember the location of each node in the Node Repository. To solve this problem, two search options are available: by exact match and by fuzzy match, both in the search box placed at the top of the Node Repository panel.

Search box

At the top of the “Node Repository” panel there is a search box. If you type a keyword in the search box and hit “Enter”, you obtain the list of nodes containing an exact match of that keyword. Press the “Esc” key to see all nodes again.

Clicking the lens on the left of the search box runs a fuzzy search algorithm leading to a wider matching result list than what found in the previous figure.

KNIME Explorer

In the top left corner of the KNIME workbench, we find the KNIME Explorer panel. This panel contains:

- Under LOCAL the workflows that have been developed in the selected workspace
- The mount points to a number of KNIME Hub spaces
- The workflows contained in the reference workspace of such Hub spaces
- The access to the My-KNIME-Hub, that is to your space on the KNIME Community Hub. Remember that you need an account with the KNIME Forum to access this space.
At the beginning, the KNIME Explorer panel only contains LOCAL, My-KNIME-Hub, and EXAMPLES. As we already stated, LOCAL shows the content of the selected workspace. EXAMPLES points to a read-only public repository, accessible via anonymous login. This repository hosts a number of example workflows that you can use to jump start a new project. My-KNIME-Hub allows to access your space on the KNIME Community Hub.

When you open KNIME Analytics Platform for the first time, you will find a folder named “Example Workflows” containing the solutions to a few common data science use cases, comprehensive of data.

Folders in “KNIME Explorer”, containing workflows, are also called “Workflow Groups”.

**Note.** KNIME Explorer panel can also host data. Just create a folder under the workspace folder, fill it with data files on the machine, and select “Refresh” in the context-menu (right-click) of the “KNIME Explorer” panel.

---

**My-KNIME-Hub**

From the KNIME Explorer panel, you can access your spaces on the KNIME Community Hub and upload and update new or existing content in there.

By default an authenticated KNIME user has a public space, for material to share publicly, and a private space to park his/her own material for further usage. However, new private or public spaces can be created with a right-click on My-KNIME-Hub in the KNIME Explorer panel and then a selection of the option “Create new Space…”.

By default, you are the only owner of your own spaces. However, when accessing this space form a web browser, after hovering on your image in the top right corner, a pen appears. This will allow to add colleagues and teammates as contributors to the space.
EXAMPLES

A link to EXAMPLES is available in the “KNIME Explorer” panel. This is a repository provided by KNIME to all users for tutorials and demos. There you can find a number of useful examples on how to implement specific tasks with KNIME. To connect to the EXAMPLES:

- double click “EXAMPLES” in the “KNIME Explorer” panel
- double click “Double click to connect…”

You should be automatically logged in as a guest.

To transfer example workflows from the EXAMPLES to your LOCAL workspace, just drag and drop or copy and paste (Ctrl-C, Ctrl-V in Windows) them from “EXAMPLES” to “LOCAL”.

You can also open the EXAMPLES workflows in the workflow editor, however only temporarily and in read-only mode. A yellow warning box on top warns that this workflow copy will not be saved.

The KNIME Explorer panel can of course host more than one KNIME Hub space. It is enough to add mount points to the list of the available KNIME Hub spaces.
Mounting KNIME Business Hub in KNIME Explorer

To add KNIME Business Hubs to the “KNIME Explorer” panel:

- Select the “KNIME Explorer” panel
- Click the “Configure Explorer View” button
- The “Preferences (Filtered)” window opens on the “KNIME Explorer” page and lists all KNIME spaces already mounted in this KNIME instance. The three KNIME spaces available by default on every KNIME instance are the local workspace “LOCAL”, the KNIME “EXAMPLES”, and the My-KNIME-Hub located on the KNIME Community Hub (hub.knime.com).
- Use the “New” and the “Remove” button to add /remove connections to remote Hub spaces.
- After clicking the “New” button, fill in the required information about the KNIME Business Hub in the “Select New Content” window (Fig. 1.19)

The same KNIME Explorer “Preferences” page can be reached via “File” in the top menu → “Preferences” → “KNIME Explorer”.

To login into any of the available KNIME Business Hubs in the “KNIME Explorer” panel:

- right-click or double-click the Hub space name
- provide the credentials
Workflow Editor

The central piece of the KNIME workbench consists of the workflow editor itself. This is the place where a workflow is built by adding one node after the other. Nodes are inserted in the workflow editor by drag and drop or double-click from the Node Repository or the Workflow Coach. The workflow building process will be described widely in the next sections of this book. Here, we will describe how to customize and probably improve the canvas role of the workflow editor space. We will describe two options:

- change the canvas appearance with grids and different visualizations for the connections;
- introducing annotations to comment the work.

Adding a grid to the canvas and curved connections to the workflows

Almost towards the end, on the right of the tool bar, you can see the “Change Workflow Editor Settings” button. If you click it, the “Workflow Editor Settings” window opens.
Customizing the Workflow Editor

The grid feature contains a few options:

1. “Show grid lines”. This shows grid lines in the workflow editor and allows to better align nodes and annotations manually.

2. “Snap to grid”. This option attaches nodes and annotations to the closest available corner of the grid. It gives you less manual freedom, but the result is cleaner and more ordered in shorter time.

3. “Curved Connections”. Here you can enable node connections to follow a curve rather than a straight line. This might lead to more appealing workflow graphics.

Adding annotations to the canvas

It is also possible to include annotations in the workflow editor. Annotations can help to explain the task of the workflow and the function of each node or group of nodes. The result is an improved documentation-like overview of the workflow general task and of the single sub-tasks.
Workflow Annotations

To insert a new annotation:

- right-click anywhere in the workflow editor and select “New Workflow Annotation”
- a pale-yellow small frame appears; this is the default annotation frame
- double-click the frame to edit its content
- Notice the tool bar appearing at the top to edit text style, font color, background color, text alignment, and border properties (color, thinkness).
- To reopen an annotation, just double-click at the top left corner, where the pencil icon is.

Other Workbench Customizations

Another possibility for customization consists of adding views. Available views are found in the “View” item in the Top menu.

Popular views, for example, are the “Node Monitor”, the “Custom Node Repository”, and the “Licenses” and “Server” views, if you have a connected KNIME Business Hub. All these extra views can be found in the Top menu under “View” → “Other” → “KNIME Views”.

The “Node Monitor” view helps, especially during the development phase, to monitor and debug the workflow execution.

The “Custom Node Repository allows for a customized “Node Repository” with only a subset of nodes.
“Licenses” allows to monitor your license situation, if you have any.

**Node Monitor View**

To insert the “Node Monitor” panel in the workbench:

- Select “View” → “Other…” in the top menu
- In the “Show View” window, expand the “KNIME Views” item and double-click “Node Monitor”; a panel, named “Node Monitor”, appears on the side of the “Console” panel; the panel shows the values for the output flow variables, the output data, or the configuration settings of the selected node in the workflow editor.
- There you can decide what to show (data, configuration, variables), via the menu in the top right corner.

![The Node Monitor View](image)

### 1.8. Download the KNIME Extensions

KNIME Analytics Platform is an open source product. As every open source product, it benefits from the feedback and the functionalities that the community develops. A number of extensions are available for KNIME Analytics Platform. If you have downloaded and installed KNIME Analytics Platform including all its free extensions, you will see the corresponding categories in the Node Repository panel, such as KNIME Labs, Text Processing, R Integration, and many others. However, if at installation time, you have chosen to install the bare KNIME Analytics Platform without the free extensions, you might need to install them separately at some point on a running instance.
Installing KNIME Extensions

To install a new KNIME extension from within KNIME Analytics Platform, there are three options.

1. From the Top Menu, select “File” → “Install KNIME Extensions”, select the desired extension, click the “Next” button and follow the wizard instructions.

2. From the Top Menu, select “Help” → “Install New Software”. In the “Available Software” window, in the “Work with” textbox, select the URL with the KNIME update site (usually named “KNIME Analytics Platform 4.x Update Site” - http://update.knime.com/analytics-platform/4.x). Then select the extension, click the “Next” button and follow the wizard instructions.

3. Search the KNIME Community Hub, on a web browser or from the KNIME Community Hub panel. When the desired extension is found, drag and drop the extension icon from the browser to the Workflow Editor.

Once the selected KNIME extension(s) has/have been installed and KNIME has been restarted, you should see the new category, corresponding to the installed extension, in the “Node Repository”.

In the “Available Software” window you can find some extension groups: KNIME & Extensions, KNIME Labs Extensions, KNIME Node Development Tools, Sources, and more. “KNIME & Extensions” contains all extensions provided for the current release; “KNIME Labs Extensions” contains a number of extensions ready to use, but not yet of x.1 release quality; “KNIME Node Development Tools” contains packages with some useful tools for Java programmers to develop nodes; “Sources” contains the KNIME source code. Specific packages donated by third parties or community entities might also be available in the list of extensions. These are usually grouped under “Community” categories. My advice is to install all extensions, even the cheminformatics ones. Many of them contain several useful nodes not necessarily restricted to a particular domain.
1.9. Data and workflows for this book

This book builds a few examples and provides the solutions to the exercises. They are contained in folder “BeginnersLuck” downloadable from the KNIME Community Hub space of one of the authors of this book. To download material from the KNIME Community Hub, you need to be logged in with your KNIME account (see how to create a KNIME account). After entering the KNIME Community Hub, in order to download the workflows, just click on the cloud icon.

- Download the whole folder onto your machine from the Beginners Luck space, which will result in a .knar file. Then:
- Double click it OR import it into the KNIME Explorer via Select File → Import KNIME Workflow …

1.2.6. Beginners Luck space on the KNIME Community Hub

At the end of the import operation, in the KNIME Explorer panel you should find a BeginnersLuck folder containing Chapter2, Chapter3, Chapter4, Chapter5, Chapter6, and Chapter7 subfolders, each one with workflows and exercises to be implemented in the next chapters. You should also find a KBLdata folder containing the required data.

The data used for the exercises and for the demonstrative workflows of this book were either generated by the author or downloaded from the UCI Machine Learning Repository, a public data repository (http://archive.ics.uci.edu/ml/datasets). If the data set belongs to the UCI Repository, a full link is provided here for download. Data generated by the author, that is not public data, are located in the KBLData folder.
Data from the UCI Machine Learning Repository:

- Adult.data: http://archive.ics.uci.edu/ml/datasets/Adult
- Iris data: http://archive.ics.uci.edu/ml/datasets/Iris
- Yellow-small.data (Balloons) http://archive.ics.uci.edu/ml/datasets/Balloons
- Wine data: http://archive.ics.uci.edu/ml/datasets/Wine

1.10. Exercises

Exercise 1
Create your own workspace and name it “book_workspace”. You will use this workspace for the next workflows and exercises.

Solution to Exercise 1

- Launch KNIME
- In Workspace Launcher window, click “Browse”
- Select the path for your new workspace
- Click “Launch”

To keep this as your default workspace, enable the option on the lower left corner.

Exercise 2
Install the following extensions:

- KNIME Database
- KNIME Javascript Views
- KNIME Report Designer

Solution to Exercise 2
From the Top Menu, select “File” → “Install KNIME Extensions”

Search and select the required Extensions

Click “Next” and follow instructions

**1.28. Exercise 2: List of KNIME Extensions**

**1.29. Exercise 2: Reporting Extension**

**Exercise 3**

Search all “Row Filter” nodes in the Node Repository.

From the “Node Description” panel, can you explain what the difference is between a “Row Filter”, a “Reference Row Filter”, and a “Nominal Value Row Filter”?

Show the node effects by using the following data tables:
Solution to Exercise 3

Row Filter

The node allows for row filtering according to certain criteria. It can include or exclude: certain ranges (by row number), rows with a certain row ID, and rows with a certain value in a selectable column (attribute). In the example below we used the following filter criterion:  \( \text{team} > 3 \)
**Reference Row Filter**

This node has two input tables. The first input table, connected to the bottom port, is taken as the reference table; the second input table, connected to the top port, is the table to be filtered. You have to choose the reference column in the reference table and the filtering column in the second table. All rows with a value in the filtering column that also exists in the reference column are kept, if the option "include" is selected; they are removed if the option "exclude" is selected.

**Reference Table**

<table>
<thead>
<tr>
<th>Ranking</th>
<th>scores</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>22</td>
</tr>
<tr>
<td>3</td>
<td>14</td>
</tr>
<tr>
<td>4</td>
<td>10</td>
</tr>
</tbody>
</table>

**Filtering Table**

<table>
<thead>
<tr>
<th>Position</th>
<th>name</th>
<th>team</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The Black Rose</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Cynthia</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>Tinkerbell</td>
<td>4</td>
</tr>
<tr>
<td>4</td>
<td>Mother</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>Augusta</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>The Seven Seas</td>
<td>3</td>
</tr>
</tbody>
</table>

**Resulting Table**

<table>
<thead>
<tr>
<th>Position</th>
<th>name</th>
<th>team</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The Black Rose</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>Tinkerbell</td>
<td>4</td>
</tr>
<tr>
<td>4</td>
<td>Mother</td>
<td>4</td>
</tr>
</tbody>
</table>

In the example above, we use "Ranking" as the reference column in the reference table and "Position" as the filtering column in the filtering table. We have chosen to include the common rows.

**Nominal Value Row Filter**
Filters the rows based on the selected value of a nominal attribute. A nominal column and one or more nominal values of this attribute can be selected as the filter criterion. Rows that have these nominal values in the selected column are included in the output data. Basically it is a Row Filter applied to a column with nominal values. Nominal columns are string columns and nominal values are the values in it.

In the example below, we use “name” as the nominal column and “name = Cynthia” as the filtering criterion.

<table>
<thead>
<tr>
<th>Original table</th>
<th>Filtered table</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Position</strong></td>
<td><strong>Position</strong></td>
</tr>
<tr>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
</tr>
</tbody>
</table>