There is a new KNIME forum. You can still browse and read content from our old forum but if you want to create new posts or join ongoing discussions, please visit our new KNIME forum: https://forum.knime.com

Square bumps on Max Filter output

Member for

3 years 9 months joshuahoran

Hi all,

 

I am using the max filter node and I notice that the output consistently shows a square bump on two of the edges (see image). Any way to suppress this? I notice this also happens for the dilate mode in the Morphological labeling node, but that doesn't happen in a reproducible manner, so I can't post a concrete example.

Thanks!

Comments
Sun, 02/25/2018 - 01:56

Member for

6 years 2 months

gab1one

Hi Joshua,

the square bumps originate from the neighborhood type setting, which is the shape of the region the filter looks in for the maximum value. You could try setting it to spherical, which will make these shapes appear round. If you reduce the Span the severity of this issue should be greatly reduced.

In the Morphological Operations nodes the shape of the neighborhood is controlled by the Structuring Element setting, you can create such an element with the Structuring Element Creator node.

best,

Gabriel

Mon, 02/26/2018 - 03:51

Member for

3 years 9 months

joshuahoran

Thanks Gabriel, I understand that the neighborhood type defines the square shape and that the image will look "blocky" as a result. However, I am referring specifically to the extra square shapes that protrude from the right and bottom sides of the circles. I thought this was strange since they don't protrude from the left or top sides. Is this a result of the algorithm applying the transformation from left to right and top to bottom?

Tue, 02/27/2018 - 10:27

Member for

6 years 2 months

gab1one

is this a result of the algorithm applying the transformation from left to right and top to bottom?

Yes, the image is usually iterated over from the top left to the bottom right. With a different iteration order you would still see these artifacts but other locations. That you get them this prominently tells me that your span setting in the max filter is too large in relation to the image size, you can try reducing it or experiment with a different filter.

Files