There is a new KNIME forum. You can still browse and read content from our old forum but if you want to create new posts or join ongoing discussions, please visit our new KNIME forum: https://forum.knime.com

Error updating to 3.5

Member for

10 years 1 month fcivardi

Hi,

updating to 3.5 I get the following error:

ERROR NativeLibBundleActivator            no liblept-4 in java.library.path
ERROR NativeLibBundleActivator            Could not load org.knime.knip.tess4j

It also cannot update KNIME Image Processing because of a conflicting dependency:Software currently installed: KNIME Image Processing - Tess4J Integration 1.3.0.v201607051537 (org.knime.knip.tess4j.feature.feature.group 1.3.0.v201607051537)
  Only one of the following can be installed at once:
    KNIME Image Types and Nodes 1.6.0.201712051444 (org.knime.knip.base 1.6.0.201712051444)
    KNIME Image Types and Nodes 1.5.6.201710240702 (org.knime.knip.base 1.5.6.201710240702)
    KNIME Image Types and Nodes 1.6.0.201712041608 (org.knime.knip.base 1.6.0.201712041608)
  Cannot satisfy dependency:
    From: KNIME Image Processing 1.6.0.201712051444 (org.knime.knip.feature.feature.group 1.6.0.201712051444)
    To: org.knime.knip.base [1.6.0.201712051444]
  Cannot satisfy dependency:
    From: KNIME Image Processing - Tess4J Integration 1.3.0.v201607051537 (org.knime.knip.tess4j.base 1.3.0.v201607051537)
    To: bundle org.knime.knip.base [1.5.0,1.6.0]
 

 

Comments
Thu, 12/07/2017 - 11:53

Member for

8 years

christian.dietz

Hi,

Please make sure that you also enabled the KNIME 3.5 Community Contrib Stable update-site when updating KNIME Image Processing. If you need advise, let us know! 

Best,

Christian

Thu, 12/07/2017 - 12:55

Member for

10 years 1 month

fcivardi

Thank you Christian, that solved  the Image Processing update error. But I still get at start the message: 

ERROR NativeLibBundleActivator            no liblept-4 in java.library.path
ERROR NativeLibBundleActivator            Could not load org.knime.knip.tess4j

And if I try to run the Tess4J node I get:

ERROR Tess4J               0:1        Error initializing Tesseract.
ERROR Tess4J               0:1        Execute failed: Unable to load library 'libtesseract-3': Native library (win32-x86-64/libtesseract-3.dll) not found in resource path (C:\Program Files\KNIME\\plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar)
 

Best

Francesco

Thu, 12/07/2017 - 02:52

Member for

8 years

christian.dietz

Hi Francesco, 

Do you work with Tess4J? If not, you can simply ignore the message or uninstall Tess4J.

Best,

Christian