There is a new KNIME forum. You can still browse and read content from our old forum but if you want to create new posts or join ongoing discussions, please visit our new KNIME forum: https://forum.knime.com

SyGMA python package install

Member for

4 years evert.homan@sc…

Hi,

I am trying to get the SyGMA node to work, but am having difficulties to install the SyGMA Python package. I am running Ubuntu 16.04 LTS, and have installed the RDKit according to http://www.rdkit.org/docs/Install.html by issuing

sudo apt-get install python-rdkit librdkit1 rdkit-data

This all works fine. However, subsequently installing the SyGMA package using pip (I do not have anaconda installed) is refused because apparently the INCHI support is not configured in the RDKit python package:

evehom@evehom-P700:~/Downloads$ pip install sygma
Collecting sygma
  Downloading SyGMa-1.1.0.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-boJjSa/sygma/setup.py", line 17, in <module>
        raise Exception('RDKit with INCHI support is required')
    Exception: RDKit with INCHI support is required
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-boJjSa/sygma/

Is there a quick fix for this?

Any tips appeciated!

Cheers/Evert

Comments
Tue, 09/26/2017 - 04:18

Member for

3 years 3 months

sverhoeven

The SyGMA package requires a RDKIT with INCHI support. The Ubuntu OS package repository contains RDKIT without INCHI support, so an `apt` install is not going to work.

You need to install miniconda (https://conda.io/miniconda.html) and then use `conda install -c 3d-e-Chem -c rdkit sygma` command to install sygma. To install miniconda you do not need root permission.

Or a more difficult option is to compile RDKit yourself with INCHI support as described at http://www.rdkit.org/docs/Install.html#building-from-source

Fri, 10/13/2017 - 03:31

Member for

4 years

evert.homan@scilifelab.se

Thank you, the miniconda approach works.

 

best regards,

 

Evert